安装oracle之后eclipse无法启动

以windowsXP为例,环境变量一般分为两种:用户变量和系统变量。用户变量存放当前用户自由的系统变量,而系统变量则存放所有用户公用的系统变量。

安装oracle9i之后,安装程序会自动将

C:\Program Files\Oracle\jre\1.3.1\bin;

自动添加到系统变量Path中,这就造成了其他使用高版本JDK的Java程序(比如Eclipse)无法启动的现象。

解决方法:
编辑系统变量Path,将

D:\java\j2sdk1.4.2_16\bin;

放到

C:\Program Files\Oracle\jre\1.3.1\bin;

之前即可。

另外,通过如下命令可以查看当前系统所用JDK版本:

C:\Documents and Settings\Administrator>java -version
java version “1.4.2_16”
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_16-b05)
Java HotSpot(TM) Client VM (build 1.4.2_16-b05, mixed mode)

此条目发表在java/j2ee分类目录,贴了标签。将固定链接加入收藏夹。

发表评论

您的电子邮箱地址不会被公开。

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据