使用Bundle进行VIM插件的管理

1.安装git:

sudo apt-get install git

2.安装Bundle:

git clone https://github.com/gmarik/vundle.git~/.vim/bundle/vundle

3.在.vimrc文件中添加如下语句

setnocompatible ” 设置vim为不兼容vi模式
filetypeoff ” required
setrtp+=~/.vim/bundle/vundle/
“如果在windows下使用,设置为
“set rtp+=$HOME/.vim/bundle/vundle/
callvundle#rc()
“let Vundle manage Vundle
Bundle’gmarik/vundle’ ” required!
“Bundles托管插件示例
“代码在github上,使用github帐号/项目名,例如:
“Bundle ‘tpope/vim-fugitive’
“代码在vimscript上,使用插件名称,插件名字可以在
“http://vim-scripts.org/vim/scripts.html页面中查找,例如:
“Bundle ‘vimwiki’
“非github的插件,使用其git地址,例如:
“Bundle ‘git://git.wincent.com/command-t.git’
filetypeplugin indent on ” required!
“Brief help
“:BundleList – list configured bundles
“:BundleInstall(!) – install(update) bundles
“:BundleSearch(!) foo – search(or refresh cache first) for foo
“:BundleClean(!) – 删除插件首先要在.vimrc中注释掉插件相应的行,再运行该命令

“see :h vundle for more details or wiki for FAQ
“NOTE: comments after Bundle command are not allowed..

4.安装插件:打开Vim→使用:BundleSearch插件名搜索插件→ 光标选定对应的候选插件,按下“i”安装该插件→ 在.vimrc文件中添加Bundle对该插件的管理语句”Bundle’XXX’ ”,XXX为插件在候选插件列表中的名字→ 可以使用bundle提供的命令对安装的插件集进行管理
注:配置文件里面“filetypeplugin indent on”会报这句“E116: Invalid arguments for function vundle#config#bundle”错误,不知道是什么原因,知道的请告诉我,谢谢。
来源:http://blog.csdn.net/tangbin330/article/details/8654770

此条目发表在lnmpa分类目录,贴了, 标签。将固定链接加入收藏夹。

发表评论

您的电子邮箱地址不会被公开。

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据